A Apple quer se livrar do Jailbreak em seus aparelhos, mas definitivamente, pelo menos os aparelhos da 1ª e 2ª geração ainda vão recorrer muito ao lado obscuro.

Já na primeira versão beta do FW 4.0 um membro do grupo iH8Sn0w, conseguiu ativar a multitarefa do FW 4.0 em iPhone 3G, para quem ainda não sabe, a Apple diz que os aparelhos anteriores a 3ª geração não suportaria este recurso.

No vídeo abaixo você confere o feito:

[youtube]http://www.youtube.com/watch?v=_8Ozp2iNbTk[/youtube]

Para entender, como já havíamos comentado no 11º episodio do TouchCast, o recurso esta presente em todos os FW 4.0 independente do modelo, o que acontece é que a Apple bloqueia/limita aos modelos que ela quer, por isso os hackers conseguiram habilitar o recurso no 3G e o mesmo pode ser feito no iPod touch 2G.

Isso de certa forma, traz uma indignação ainda maior aos proprietários de iPhones e iPods touch de 1ª geração que não terão sequer a nova versão do firmware.

Resta agora saber se a Apple vai tentar atrapalhar os planos dos Hackers e dificultar ou então eliminar de vez a possibilidade de ativar o recurso, afinal essa é ainda a 1ª versão beta.

T+